I was made Sys Admin, now I cannot access any of the sales portion of Dynamics

Question Status

Suggested Answer
Alec Gupton asked a question on 11 Apr 2018 9:45 AM

Insufficient Permissions
You do not have permission to access these records. Contact your Microsoft Dynamics 365 administrator. If you contact support, please provide the technical details.
Activity ID: 726aca27-54b4-4dfc-a7c6-96245a454304

I've checked my role, team, business unit, etc. It all is correct. 

Reply
Suggested Answer
Ravi Kashyap responded on 11 Apr 2018 11:44 PM

Hi Alec,

If you have System Administrator role then you should not get this error message. Could you please share the log file, screenshot of the role you have?

Also, is it happening when you open dashboard or other entities as well?

Hope this helps.

Reply
Alec Gupton responded on 13 Apr 2018 8:09 AM

Ravi,

Thank you for responding. On the dashboard every iframe says "Insufficient privileges, contact your sys admin....." When I try clicking on a recently viewed sales account, that is when I can view an error log.

Error log pasted below:

Unhandled Exception: System.ServiceModel.FaultException`1[[Microsoft.Xrm.Sdk.OrganizationServiceFault, Microsoft.Xrm.Sdk, Version=8.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #26AD0E04Detail:

<OrganizationServiceFault xmlns:i="www.w3.org/.../XMLSchema-instance&quot; xmlns="schemas.microsoft.com/.../Contracts&quot;>

 <ActivityId>5f768030-e1a8-4874-83ce-48ce29c67cd4</ActivityId>

 <ErrorCode>-2147220970</ErrorCode>

 <ErrorDetails xmlns:d2p1="schemas.datacontract.org/.../System.Collections.Generic&quot; />

 <Message>System.Web.HttpUnhandledException: Microsoft Dynamics CRM has experienced an error. Reference number for administrators or support: #26AD0E04</Message>

 <Timestamp>2018-04-13T13:08:25.9864155Z</Timestamp>

 <ExceptionRetriable>false</ExceptionRetriable>

 <ExceptionSource i:nil="true" />

 <InnerFault>

   <ActivityId>5f768030-e1a8-4874-83ce-48ce29c67cd4</ActivityId>

   <ErrorCode>-2147220960</ErrorCode>

   <ErrorDetails xmlns:d3p1="schemas.datacontract.org/.../System.Collections.Generic&quot; />

   <Message>Principal user (Id=0fdd6551-5200-e811-8124-e0071b7284d1, type=8) is missing prvReadAccount privilege (Id=886b280c-6396-4d56-a0a3-2c1b0a50ceb0)</Message>

   <Timestamp>2018-04-13T13:08:25.9864155Z</Timestamp>

   <ExceptionRetriable>false</ExceptionRetriable>

   <ExceptionSource i:nil="true" />

   <InnerFault i:nil="true" />

   <OriginalException i:nil="true" />

   <TraceText i:nil="true" />

 </InnerFault>

 <OriginalException i:nil="true" />

 <TraceText i:nil="true" />

</OrganizationServiceFault>

Reply
Suggested Answer
Jamie Ells responded on 13 Apr 2018 9:34 AM

Have you tried "Promote to Admin" button with your user account selected?

Reply
TonyN responded on 13 Apr 2018 10:18 AM

I would guess that you are not a licensed user. You can be admin without a license, but you will not have access to the data. Check to see if your Access Mode is "Administrative" on your user record.

Reply
Suggested Answer
JRay101 responded on 13 Apr 2018 2:49 PM

I've have received this before on entities I should have had full access too ... try resetting your browser cache and cookies or try in a different browser or machine.

Reply
Adam Vero responded on 14 Apr 2018 5:36 AM

Sounds like your user record has been set to "Administrative" access mode, designed to allow to you to admin the system without accessing core data (and used to mean no licence required, but not sure if that still stands)

Reply
Suggested Answer
Ravi Kashyap responded on 11 Apr 2018 11:44 PM

Hi Alec,

If you have System Administrator role then you should not get this error message. Could you please share the log file, screenshot of the role you have?

Also, is it happening when you open dashboard or other entities as well?

Hope this helps.

Reply
Suggested Answer
Jamie Ells responded on 13 Apr 2018 9:34 AM

Have you tried "Promote to Admin" button with your user account selected?

Reply
Suggested Answer
JRay101 responded on 13 Apr 2018 2:49 PM

I've have received this before on entities I should have had full access too ... try resetting your browser cache and cookies or try in a different browser or machine.

Reply