SBX - Search With Button

SBX - Forum Post Title

Activity tab not appearing on social pane

Microsoft Dynamics CRM Forum

lspils asked a question on 29 Jun 2016 3:46 AM

Question Status

Verified

I have created a custom entity on our crm, With a simple form and added on the social pane, the Notes tab appears but activity's do not when publishing the form. In preview mode it works and I can add activity's to the pane. I can even make a test/dummy post in preview mode and that appears in the activity log but the tab still doesn't appear on the form.

On the test/dev install of CRM this work flawless on my custom entity.

Can anyone shed some light on why its not showing ? or how I can get it back. I have tried to recreate the form but the bug still happens on the custom entity...

Reply
Suggested Answer

Hello,

Have you checked activities checkbox in entity customization form:

Reply
lspils responded on 29 Jun 2016 4:57 AM

Yes Andrii first thing i checked its 100% ticked

Reply

Ok. Could you please provide a screenshot how does it look like?

Reply
lspils responded on 29 Jun 2016 5:13 AM

Yes mate np 

Live view

Entity settings

Reply

Try to delete social pane, save form, publish form, put it back, save, publish.

Reply
lspils responded on 29 Jun 2016 5:25 AM

Did try that, but will try again just to be sure. Cheers

Reply
lspils responded on 29 Jun 2016 5:38 AM

Tried leaves me with the same result only the Notes pane is visible on the entity.

Reply
Suggested Answer

In such situation I'm afraid that the only way is to open support ticket.

Reply
lspils responded on 29 Jun 2016 5:59 AM

No problem Andrii thanks for trying to help.

Reply
Vijay K responded on 15 May 2017 9:33 PM
My Badges

Hi Ispils,

Were you able to resolve this issue? I am also having the same issue on Activities even though it is ticked for a Custom Entity. Please respond.

Reply
Mohd Saad Akhtar responded on 15 May 2017 11:16 PM
My Badges
Suggested Answer

Please remove social pane from your form and publish it. After that put Social Pane again and publish it.

Refer this if above doesn't resolve the issue:

nishantrana.me/.../missing-activities-tab-in-social-pane-in-crm-2013

Reply
lspils responded on 16 May 2017 3:02 AM

HI VJ From what I can remember the only way to resolve the issue was to recreate the custom entity, I cant remember fixing it any other way.
I believe I tried Mohd Saad Akhtar fix but it didn't work for me, give it a try see if it works for you.


Reply
Steeve Gauvreau responded on 23 May 2017 2:06 PM
My Badges

I'm having the same issue.

Recreating the entity is not really an option for me. Any suggestions will be appreciated

Reply
David Rowland responded on 4 Dec 2017 8:08 AM
My Badges

Saad Akhtar

Please remove social pane from your form and publish it. After that put Social Pane again and publish it.

Refer this if above doesn't resolve the issue:

nishantrana.me/.../missing-activities-tab-in-social-pane-in-crm-2013

I had this issue on out of box Contact entity so not possible for me to recreate - this solution worked for me. It's worth noting that this setting is entity and form specific so you may have to change FormPresentation value multiple times in the XML - it won't be the first option that you come to.

Reply

To close the thread here is solution that worked for my colleague superstar :

The solution was to create a new form. Editing the existing form or saving as a new form didn't work, but hitting the new button and creating a new form worked.
Create a new form, remove the notes pane, publish, add notes pane, publish did the trick.

Reply
Joel Lindstrom responded on 8 Nov 2018 11:10 AM
My Badges
Verified Answer

found a fix for this. Create a new form (not save as new, but new form), remove the social pane/timeline control, save and publish, re-add the timeline control, save and publish.

Reply
Suggested Answer

Hello,

Have you checked activities checkbox in entity customization form:

Reply
Suggested Answer

In such situation I'm afraid that the only way is to open support ticket.

Reply
Mohd Saad Akhtar responded on 15 May 2017 11:16 PM
My Badges
Suggested Answer

Please remove social pane from your form and publish it. After that put Social Pane again and publish it.

Refer this if above doesn't resolve the issue:

nishantrana.me/.../missing-activities-tab-in-social-pane-in-crm-2013

Reply

SBX - Two Col Forum

SBX - Migrated JS