Hi, yesterday in one of our customers with v9 online, any attempt to update a plugin produces the following message:
Currently, Microsoft Dynamics 365 requires the .NET Framework version 4.6.2 for plug-in assemblies. Rebuild the assembly with the .NET Framework version 4.6.2 and try again.
I am pretty sure we are building the plug-ins using version 4.6.2 (with VS 2015), and we are using SDK libraries obtained from NuGet, but D365 still shows the same error. As usual, I would appreciate your guidance and advise.
could you post a screenshot of the target framework version for your plugin project?
Thanks Alex. Please see the attached image:
I just created a new solution using only version .net framework 4.6.2, recompile but I am getting the same error. Indeed, the full error is this:
This plug-in assembly uses the version obtenerUsuarioAsignacion, Version = 188.8.131.52, Culture = neutral, PublicKeyToken = 6a0cb0ef57054135 from the .NET Framework. Currently, Microsoft Dynamics 365 requires the .NET Framework version 4.6.2 for plug-in assemblies. Rebuild the assembly with the .NET Framework version 4.6.2 and try again.
I found an answer that works for me in this link: community.dynamics.com/.../280013
I changed the .net framework target to 4.5.2 and keep the v9 SDK libraries and I was able to update the plugins. Not sure why this is working this way even though Microsoft requieres a higher .net framework version.
When you get time, could you try the same in VS2017 targetting .NET 4.6.2 and v9 DLLs?
I am getting this issue since last week. I am using VS2017 with all the updates, v9 SDKs and 4.6.2 .NET framework. Swopping to use 4.5.2 does not work either...
I can confirm this issue is still present. My plugins are configured to use .NET 4.6.2. I cannot update any of them in Dynamics 365 Online. I've just updated my Dynamics Core dlls to 184.108.40.206 and nothing changed. I'm still unable to deploy updates to my plugins.
Switching to 4.5.2 didn't work for me either. I actually went further and saved my steps in a solution file and deleted my plugin dll. I tried to use both 4.5.2. and 4.6.2 and neither one worked.
I have managed to deploy my custom workflow by cleaning my project building as 4.5 and deploying. However trying to move the solution file to live gives me the same error as before on import. I will try and redeploy tomorrow using 4.6.2 and reinstalling the framework locally as an additional test
I have the same issue today.
It was ok on Friday 5pm, 11 May 2018, Brisbane time.
I have to change back to 4.5.2, then it works.
I managed to get it working with .NET 4.5.2 after finding that one of the Crm sdk dlls was set to be copied into the local folder and since I was using ILMerge, it led to an error. But I can definitely confirm that .NET 4.6.2 didn't work.
We have the same problem as of this morning, have anybody found a solution ?
Our DLL's have the always been build wint .net 4.6.2, and now we cannot update the assemblies..
PLZ Help !!
We are having the same problem this morning - reverting to 4.5.2 has fixed it but where do we go from here - leave it a 4.5.2? What happens in the future - should we upgrade back to 4.6.2?
Our project was never on 4.5.2, worked fine last week ..
ours was fine until today - we deployed 4.6.2 to both dev and test last week no problems
The issue is misleading and inconsistent. In My organisation the below things Happened
1. If Plugin assembly and workflow assembly both are in 4.6.2, it fails
2. If Plug in is in 4.52 and workflow is 4.6.2 things works fine
For a temporary fix change the version to 4.5.2 it should work as it worked for me
There are a couple of things causing confusion here.
1. The last few versions of Dynamics 365 require .NET version 4.5.2 for plugins as outlined at docs.microsoft.com/.../write-plugin
2. Dynamics 365 v9 recently started strictly enforcing this requirement when it didn't before.
3. There is a product defect in the error message thrown, where the current .NET version of the assembly is shown instead of "4.5.2".
If you're absolutely sure that you're building against 4.5.2 and still seeing this error, there is something else going on. But, the majority of these posts should fall in to the above category.
Bottom line: You must use .NET 4.5.2.
Business Applications communities